using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.+?):([a-z]+)\s(contextref)(="")(.+?)""\s(decimals)(="")(.+?)""\s(unitref)(="")(.+?)"">(.+?)<\/(.+?):([a-z]+)>";
string input = @"<ifrs-full:deferredtaxrelatingtoitemschargedorcrediteddirectlytoequity contextref=""Duration_Actual_PerdidasFiscales_1"" decimals=""-3"" unitref=""CLP"">-4088611000</ifrs-full:deferredtaxrelatingtoitemschargedorcrediteddirectlytoequity>,
<ifrs-full:deferredtaxrelatingtoitemschargedorcrediteddirectlytoequity contextref=""Duration_Actual_UnusedTaxLossesMember"" decimals=""-3"" unitref=""CLP"">-4088611000</ifrs-full:deferredtaxrelatingtoitemschargedorcrediteddirectlytoequity>,
<ifrs-full:deferredtaxrelatingtoitemschargedorcrediteddirectlytoequity contextref=""TrimestreAcumuladoActual"" decimals=""-3"" unitref=""CLP"">-4088611000</ifrs-full:deferredtaxrelatingtoitemschargedorcrediteddirectlytoequity>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}