import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(((\\{(?:[^\\{\\}]+|(?-1))+\\})|\\((?:[^(),]+,[^(),]+)\\)|[^()\\{\\},]+)(?:,(?2))+),";
final String string = "Should work for:\n"
+ "(1,2,3)\n"
+ "(1,2,3,4)\n"
+ "((1,2),3,4)\n"
+ "(((1,2,3),4),5)\n"
+ "({x},{y},{z})\n"
+ "(1,(2,3),4)\n"
+ "((1,2),(3,4),5)\n"
+ "((1,2),3,(4,5))\n"
+ "(1,(2,(3,4),5))\n"
+ "(1,(2,({3},4),5))\n"
+ "(1,{{1},{1,2}},3)\n\n"
+ "Should not work for:\n"
+ "(1,2)\n"
+ "(10,10)\n"
+ "(1,10)\n"
+ "((1,2),3)\n"
+ "(((1,1),1),1)\n"
+ "({0},1)\n"
+ "({{x},{x,y}},z)";
final String subst = "($1),";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}