$re = '/^(?=\D*\d)(?=.*\S\$).{2,}$/m';
$str = 'world9 a9$ b6$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);