import Foundation
let pattern = #".*\: Service \[ssmtp\] accepted connection from ::ffff:\d+\.\d+\.\d+\.\d+:\d+\n.* s_connect: connect ::1:25: Connection refused \(61\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2019.04.12 10:16:22 LOG5[4]: Service [ssmtp] accepted connection from ::ffff:185.222.209.224:24846
2019.04.12 10:16:22 LOG3[4]: s_connect: connect ::1:25: Connection refused (61)
2019.04.12 10:16:22 LOG5[4]: s_connect: connected 127.0.0.1:25
2019.04.12 10:16:22 LOG5[4]: Service [ssmtp] connected remote server from 127.0.0.1:54674
2019.04.12 10:16:30 LOG5[3]: Connection closed: 232 byte(s) sent to TLS, 84 byte(s) sent to socket
2019.04.12 10:16:30 LOG5[5]: Service [ssmtp] accepted connection from ::ffff:193.57.40.242:62532
2019.04.12 10:16:31 LOG3[5]: s_connect: connect ::1:25: Connection refused (61)
2019.04.12 10:16:31 LOG5[5]: s_connect: connected 127.0.0.1:25
2019.04.12 10:16:31 LOG5[5]: Service [ssmtp] connected remote server from 127.0.0.1:54681
2019.04.12 10:16:31 LOG5[4]: Connection closed: 232 byte(s) sent to TLS, 70 byte(s) sent to socket
2019.04.12 10:16:42 LOG5[5]: Connection closed: 190 byte(s) sent to TLS, 34 byte(s) sent to socket
2019.04.12 10:16:43 LOG5[6]: Service [ssmtp] accepted connection from ::ffff:193.57.40.242:13878
2019.04.12 10:16:45 LOG3[6]: s_connect: connect ::1:25: Connection refused (61)
2019.04.12 10:16:45 LOG5[6]: s_connect: connected 127.0.0.1:25
2019.04.12 10:16:45 LOG5[6]: Service [ssmtp] connected remote server from 127.0.0.1:54688
2019.04.12 10:16:49 LOG5[6]: Connection closed: 232 byte(s) sent to TLS, 68 byte(s) sent to socket
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)