import re
regex = re.compile(r"^(?=\s*[^\s#]).*", flags=re.MULTILINE)
test_str = " # comment"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)