#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<!--[\s\S]*?-->|(?P<url>(http(s?):)?\/?\/?[^,;" \n\t>]+?\.(jpg|gif|png))"
Local $sString = "<img src="/images/lol/hallo.png" />" & @CRLF & _
" /images/lol/hallo.png" & @CRLF & _
" /images/lol/hallo.png" & @CRLF & _
" //example.com/images/lol/hallo.png" & @CRLF & _
" http://example.com/images/lol/hallo.png" & @CRLF & _
" https://example.com/images/lol/hallo.png" & @CRLF & _
" <!-- /images/lol/commented.png -->" & @CRLF & _
" <!-- <img src="/images/lol/commented2.png" /> -->" & @CRLF & _
" images/ui/paper-icon-1.png" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/images/lol/hallo.png and more here /images/lol/hallo.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")