const regex = /(^( +|)\[(?<name>[^#;\r\n]+)\])|(^( +|)(?<key>[^\[\]\r\n=#;]+)( |)=( |)(?<value>[^#;\\\r\n]*(?:\\.[^#;\\\r\n]*)*))|((#|;)(?<comm>.+)$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^( +|)\\[(?<name>[^#;\\r\\n]+)\\])|(^( +|)(?<key>[^\\[\\]\\r\\n=#;]+)( |)=( |)(?<value>[^#;\\\\\\r\\n]*(?:\\\\.[^#;\\\\\\r\\n]*)*))|((#|;)(?<comm>.+)$)', 'gm')
const str = `;An orphan comment at the top of the file
#Another orphan comment
#Comment above a group
[Group1] #Group comment 1
Key1=Value1#Comment 1
Key2=Value 2
Key 3=Value 3
Key 4=Value4
Key5=Value \\#5;Comment 2
;Another comment above a group
[Group 2] ;Group comment 2
Key1 = Value1 #Comment 3
Key2 = Value 2
Key 3 = Value 3
Key 4 = Value4
Key 5 = Value\\;5 ;Comment 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}