using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|,)(?=[^""]|("")?)""?(((?:[^""]|"")*|[^,""]*))""?(?=,|$)";
string input = @",2.99,AMO024,Title,""Description, more info"",,123987564
123,2.99,AMO024,Title,""Description, more info"",,123987564
""""test"" test"",""test""fdas""fdad"",
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}