import re
regex = re.compile(r"^(SomeClue=someText|AnotherClue=somethingElse|YetAnotherClue=moreText),(?1),(?1)$", flags=re.MULTILINE)
test_str = ("SomeClue=someText,AnotherClue=somethingElse,YetAnotherClue=moreText\n"
"SomeClue=someText,YetAnotherClue=moreText,AnotherClue=somethingElse\n"
"AnotherClue=somethingElse,SomeClue=someText,YetAnotherClue=moreText\n"
"YetAnotherClue=moreText,SomeClue=someText,AnotherClue=somethingElse\n\n"
"SomeClue=someText,AnotherClue=somethingElse,YetAnotherClue=moreText, SomeClue=someText,YetAnotherClue=moreText,,AnotherClue=somethingElse\n"
",AnotherClue=somethingElse,SomeClue=someText,YetAnotherClue=moreText\n"
"YetAnotherClue=moreText,SomeClue=someText,AnotherClue=somethingElse,UselessText\n"
"YetAnotherClue=moreText,SomeClue=someText,AnotherClue=somethingElse,AClueThatIDontWant=wrongwrongwrong")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")