package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(\d{3}\) \d{3}-\d{4};ext=\d{2}`)
var str = `(123) 456-7890;ext=12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}