$re = '/\(\d{3}\) \d{3}-\d{4};ext=\d{1,10}/m';
$str = '(123) 456-7890;ext=12345
(123) 456-7890;ext=123412
(123) 456-7890;ext=12345897';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);