const regex = /^\d+\.\d+\s(?:(?!^\d+\.\d+\s).)*\bTEST\b(?:(?!^\d+\.\d+\s).)*/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\.\\d+\\s(?:(?!^\\d+\\.\\d+\\s).)*\\bTEST\\b(?:(?!^\\d+\\.\\d+\\s).)*', 'gms')
const str = `asdasdasda
2.1 adasdasdasdasdwvwetwevtwtv
wetvwetv TEST wqrqwvrqw
qwvrqwvqwr
2.2 whergtvwe
wetvwetvwetveatw
evtwet
2.3 eyrnenytunrunert
vqevrerwv TEST aevtawtvwetv
wetvwetv TEST wqrqwvrqw
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}