import Foundation
let pattern = #"(?<text>.*)(?<newline>[\r\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abcdef
ghijkl
mnrstu
vwxyz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${text}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)