$re = '/[^\s=]+=\(([^)]*)\)/m';
$str = 'title=(example1) caption=(example2) button=(example3) price=(example4) off=(example5)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);