# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Script module: (?<scriptModule>.*)\W\W\W\s(?<lastLine>[\W\w]+)$"
test_str = ("12/10/2019 07:40:23 AM\n"
" LogName=ARAdminService\n"
" SourceName=ARAdminSvc\n"
" EventCode=1521\n"
" EventType=4\n"
" Type=Information\n"
" ComputerName=wmidcars73.idexcorpnet.com\n"
" User=NOT_TRANSLATED\n"
" Sid=S-1-5-21-2094280246-649338158-1033845588-46148\n"
" SidType=0\n"
" TaskCategory=ScheduledTask\n"
" OpCode=Info\n"
" RecordNumber=11331718\n"
" Keywords=Classic\n"
" Message=Scheduled task has reported an event. \n"
" \n"
" Task ID: 089546a0-3a4b-4b66-9e4e-43bc9a1f48a6 \n"
" \n"
" Object name: Exo-Process-Changes \n"
" \n"
" Start date: 12/10/2019 \n"
" \n"
" Start time: 7:40:00 AM \n"
" \n"
" Script module: Exo-Process-Changes \n"
" \n"
" Task execution was completed")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.