const regex = /^[a-z]+\/(?!index)[a-z]+(?!-bundle)(?:-[a-z]+)?\.js$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]+\\\/(?!index)[a-z]+(?!-bundle)(?:-[a-z]+)?\\.js$', 'gm')
const str = `test/test.js
hey/test-bundle.js
test/test-heybundle.js
test/index.js
test/indop.js
lollipop/testindex.js
test/test.scss
test/test.css
lalilu/hey.yml
test.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}