# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<(?:p)\b[^>]*?color\s*:\s*(?:(black))[^>]*?>(?(1)(?:\s*<span\b[^>]*?>)?)|<span\b[^>]*?color\s*:\s*black[^>]*?>)(?s)\s*<code\b(?:\".*?\"|'.*?'|[^>]*?)+>(*SKIP)(*FAIL)|<code\b[^>]*?style[^>]*?background-color\s*:\s*transparent[^>]*?>"
test_str = ("<html>\n"
"<p style=\"font-family: "verdana"; font-size: 18px; color: black; line-height: 18px; text-align: justify; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: cyan;\"><span style=\"font-size: 13.5pt; font-family: "Verdana","sans-serif";\"><code style=\"background-color: transparent;\"><b>some text here</b></code></span></p>\n"
"<span><span style=\"font-size: 13.5pt; font-family: "Verdana","sans-serif"; background-color: cyan;\"><code style=\"background-color: transparent;\"><b>some text here</b></code></span>\n\n"
"<code style=\"background-color: transparent;\">\n\n"
"<p style=\"font-family: "verdana"; font-size: 18px; color: cyan; line-height: 18px; text-align: justify; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: cyan;\"><span style=\"color: black; font-size: 13.5pt; font-family: "Verdana","sans-serif";\"><code style=\"background-color: transparent;\"><b>some text here</b></code></span></p>\n"
"<span><span style=\"font-size: 13.5pt; font-family: "Verdana","sans-serif"; background-color: cyan;\"><code style=\"background-color: transparent;\"><b>some text here</b></code></span>\n"
"<p style=\"font-family: "verdana"; font-size: 18px; color: cyan; line-height: 18px; text-align: justify; font-style: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px; background-color: navy;\"><span style=\"font-size: 13.5pt; font-family: "Verdana","sans-serif";\"><code style=\"background-color: transparent;\"><b>some text here</b></code></span></p>\n"
"</html>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.