$re = '/\.([^._]*(_[^._]*){0,2})[^.]*$/m';
$str = 'ABC_Simple_DEF.dbo.GDE_1_1_Contact_test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);