import re
regex = re.compile(r"^weight.+average.+(\n.+){0,2}(share|basic|ordinary).+(?P<d1>\s[\d,]+)\s+(?P<d2>\s[\d,]+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("VITROX CORPORATION BERHAD \n"
"(Incorporated in Malaysia) \n"
"Company No: 200401011463 (649966-K) \n"
"QUARTERLY REPORT ON RESULTS FOR THE SECOND QUARTER ENDED 30 JUNE 2020 \n"
"B. DISCLOSURE REQUIREMENTS AS SET OUT IN APPENDIX 9B OF BURSA SECURITIES \n"
"MAIN MARKET LISTING REQUIREMENTS (cont’d) \n"
"B10 Earnings per share \n"
"INDIVIDUAL QUARTER CUMULATIVE QUARTER\n"
"Corresponding\n"
"Corresponding Current preceding\n"
"Current quarter preceding period-to-date period-to-date\n"
"ended quarter ended ended ended\n"
"30-Jun-20 30-Jun-19 30-Jun-20 30-Jun-19\n"
"Profit attributable to owners of \n"
"the Company (RM'000) 22,922 24,387 43,987 48,003\n"
"Weighted average number of\n"
"shares for computing basis\n"
"earnings per share ('000) 471,092 470,718 471,092 470,718\n"
"Basic earnings per share (sen) 4.87 5.18 9.34 10.20\n"
"Weighted average number of\n"
"shares for computing diluted \n"
"earnings per share ('000) 472,121 4 71,896 472,121 471,896\n"
"Diluted earnings per share (sen) 4.86 5.17 9.32 10.17\n"
"B11 Auditors’ report on preceding annual financial statements \n"
"The auditors’ report on the financial statements for the year ended 31 December 2019 was not subject to \n"
"any qualification. \n"
"13 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")