import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=src=\").*?(?=[\\?\"])";
final String string = "<iframe src=\"http://www.youtube.com/embed/NM51qOpwcIM?modestbranding=1;rel=0;showinfo=0;autoplay=0;autohide=1;yt:stretch=16:9;wmode=transparent;?wmode=transparent\" allowfullscreen=\"\" style=\"width: 640px; height: 361.057px;\" frameborder=\"0\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/VASywEuqFd8?feature=oembed\" allowfullscreen=\"\" width=\"660\" height=\"371\" frameborder=\"0\"></iframe>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}