package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z]|[a-z])+$`)
var str = `dsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuiorudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuiorudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafs;dafhjweioqroweuiorudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuiorudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}