re = /^([a-z]|[a-z])++$/m
str = 'dsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuiorudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuiorudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafs;dafhjweioqroweuiorudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuiorudsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweuioruiosdjafjlkjdsafdsafsdafhjweioqroweu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end