#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<![^,])([^,]+)(?:,\s*\1)+(?![^,])"
Local $sString = "abc,def,fgh,fgh,xna,fgh,xyz,xyz,xyz,tr,tr,xna"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)