$re = '/(...\w)_(.\d)(.\d)_(.\d)_(.\w)_(...\w)_(.\d)_(\d)*(.*)/m';
$str = 'CITY_0212_00_V1_SZEG_24_1.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);