$re = '/<ul>(<li>((.|\n)*?)<\/li>)<\/ul>/i';
$str = '<div><ul><li>SOME TEXT INSIDE<br></li></ul></div>';
$subst = "<span class=\"text_right\">$2</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;