using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:outcome|disposition): ?court of appeals'? ?judgments?.*?)(?:(?:\.|;|:|,? ?and|,)? ?(?:trial|circuit|chancery) court(?:'s)? ?judgment)";
string input = @"DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED. THE JUDGMENT OF THE CHICKASAW COUNTY CIRCUIT COURT IS AFFIRMED IN PART AND REVERSED IN PART AND REMANDED.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED. THE JUDGMENT OF THE HINDS COUNTY CIRCUIT COURT IS AFFIRMED IN PART AND REVERSED IN PART, AND THE CASE IS REMANDED.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED. THE JUDGMENT OF THE WARREN COUNTY CIRCUIT COURT IS AFFIRMED IN PART, REVERSED IN PART AND THE CASE IS REMANDED.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED IN PART AND REVERSED IN PART AND THE JUDGMENT OF THE TRIAL COURT IS REINSTATED AND AFFIRMED.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED IN PART AND REVERSED IN PART. THE JUDGMENT OF THE HANCOCK COUNTY CHANCERY COURT IS AFFIRMED.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED IN PART AND REVERSED IN PART. THE JUDGMENT OF THE CIRCUIT COURT OF DESOTO COUNTY IS REINSTATED AND AFFIRMED.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED IN PART AND REVERSED IN PART. THE JUDGMENTS OF THE CIRCUIT COURT OF CLARKE COUNTY AND THE CIRCUIT COURT OF NEWTON COUNTY ARE AFFIRMED.
DISPOSITION: Court of Appeals judgment reversed. Trial court's judgment affirmed.
OUTCOME: The court reversed the judgment of the intermediate court, and reinstated and affirmed the judgment entered by the trial court. The trial court did not abuse its discretion in refusing to set aside the default judgment.
OUTCOME: The judgment of the court of appeals was reversed and rendered and the judgment of the trial court was reinstated and affirmed.
DISPOSITION: The judgment of the Court of Appeals is affirmed. The judgment of the Warren County Circuit Court is reversed and remanded for further proceedings consistent with this opinion.
DISPOSITION: Court of Appeals judgment reversed. Trial court's judgment affirmed.
DISPOSITION: Judgment of Court of Appeals reversed, and judgment of Circuit Court affirmed.
DISPOSITION: Judgment of Court of Appeals reversed; judgment of Trial Court reinstated and affirmed.
DISPOSITION: JUDGMENT OF THE COURT OF APPEALS AFFIRMED IN PART AND REVERSED IN PART, AND JUDGMENT OF CHANCERY COURT AFFIRMED IN PART AND REVERSED AND REMANDED IN PART.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED IN PART AND REVERSED IN PART. THE JUDGMENT OF THE CIRCUIT COURT OF LOWNDES COUNTY IS AFFIRMED IN PART, VACATED IN PART, AND THE CASE IS REMANDED FOR RESENTENCING.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED IN PART AND VACATED IN PART, AND THE JUDGMENT OF THE CIRCUIT COURT IS AFFIRMED IN PART AND REVERSED AND REMANDED IN PART.
DISPOSITION: COURT OF APPEALS' JUDGMENT AFFIRMED, AND CHANCERY COURT'S JUDGMENT REVERSED AND REMANDED.
DISPOSITION: JUDGMENT OF THE COURT OF APPEALS IS AFFIRMED; JUDGMENT OF THE CIRCUIT COURT OF HINDS COUNTY IS REVERSED AND RENDERED.
DISPOSITION: THE JUDGMENT OF THE COURT OF APPEALS AFFIRMED, AND THE JUDGMENT OF THE FORREST COUNTY CIRCUIT COURT REVERSED AND RENDERED.
DISPOSITION: COURT OF APPEALS REVERSE, TRIAL COURT AFFIRMED.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}