#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\?first=)[^&]+"
Local $sString = "http://www.example.com.tr/?first=DSPN47ZTE1BGMR&second=NECEFT8RYD" & @CRLF & _
"http://www.example.com.tr/?first=RTR22414242144&second=YUUSADASFF" & @CRLF & _
"http://www.example.com.tr/?first=KOSDFASEWQESAS&second=VERERQWWFA" & @CRLF & _
"http://www.example.com.tr/?first=POLUJYUSD41234&second=13F241DASD" & @CRLF & _
"http://www.example.com.tr/?first=54SADFD14242RD&second=TYY42412DD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")