#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Try upload file :\s+Upload File (?<file>.*?)\s+(?<msg>\w+,[^.]+\.)\s+Closing log at (?<time>\d+:\d+:\d+\s+\w+) on (?<date>\d+\/\d+\/\d+)"
Local $sString = "" & @CRLF & _
"======================================================================" & @CRLF & _
"TGS" & @CRLF & _
"======================================================================" & @CRLF & _
"Opening log at 1:58:03 PM on 4/29/2016" & @CRLF & _
"" & @CRLF & _
"Parameters :" & @CRLF & _
"TargetFile:" & @CRLF & _
"GeneratedControlFile:False" & @CRLF & _
"Path and filename : " & @CRLF & _
"Try upload file : " & @CRLF & _
"Upload File D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\AppointLetters_2016_3_25_14_30.csv Complete, status : 226 Transfer complete." & @CRLF & _
"" & @CRLF & _
"Path and filename : D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\AppointLetters_2016_3_25_14_30.csv" & @CRLF & _
"Try upload file : " & @CRLF & _
"Upload File D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\AppointLetters_2016_3_26_14_30.csv Complete, status : 226 Transfer complete." & @CRLF & _
"" & @CRLF & _
"Path and filename : D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\AppointLetters_2016_3_26_14_30.csv" & @CRLF & _
"Try upload file : " & @CRLF & _
"Upload File D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\AppointLetters_2016_3_27_13_30.csv Complete, status : 226 Transfer complete." & @CRLF & _
"" & @CRLF & _
"Path and filename : D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\BAAppointmentLetters_2016_4_7_13_0.csv" & @CRLF & _
"Try upload file : " & @CRLF & _
"Upload File D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\BAAppointmentLetters_2016_4_8_13_0.csv Complete, status : 226 Transfer complete." & @CRLF & _
"" & @CRLF & _
"Path and filename : D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\BAAppointmentLetters_2016_4_8_13_0.csv" & @CRLF & _
"Try upload file : " & @CRLF & _
"Upload File D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\BAAppointmentLetters_2016_4_9_13_0.csv Complete, status : 226 Transfer complete." & @CRLF & _
"" & @CRLF & _
"Path and filename : D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\BAAppointmentLetters_2016_4_9_13_0.csv" & @CRLF & _
"Try upload file : " & @CRLF & _
"Upload File D:\Program Files\X529\Matrix IT Software PK\PTS\Files\JobLettrers\BAAppointmentLetters_2016_4_9_13_0.csv Complete, status : 226 Transfer complete." & @CRLF & _
"" & @CRLF & _
"Closing log at 2:00:56 PM on 4/29/2016" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")