// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?xui)(?(DEFINE) #Это блок с объявлением функций
#Этот блок - единственное место, где нужно подставлять значения
(?<tagName>ul) #Имя тега
(?<attrName>class) #Атрибут тега
(?<attrValue>ul) #Значение тега
(?<anyAttrName>[^\s\>\=]*+) #Любое название атрибута
(?<anyAttrValue>\"[^\"]*+\"|\'[^\']*+\'|\`[^\']*+\`|[^\s\>]*+) #Любое значение атрибута
(?<anyAttr>(?&anyAttrName)\s*+(?:\=\s*+(?&anyAttrValue)\s*+)?+) #Любой атрибут
#Если нужно найти точное вхождение значения атрибута
(?<attr>
(?&attrName)\b\s*+\=\s*+ #Нужное нам название атрибута
(?: #Поиск точного вхождения
\"(?&attrValue)\"|
\'(?&attrValue)\'|
\`(?&attrValue)\`|
(?&attrValue)(?=[\s\>])
)
)
#Если нужно искать в атрибуте значение как в классах
(?<attrClass>
(?&attrName)\b\s*+\=\s*+ #Нужное нам название атрибута
(?: #Поиск значения как в классах
\"[^\"]*?\b(?&attrValue)\b[^\"]*+\"|
\'[^\']*?\b(?&attrValue)\b[^\']*+\'|
\`[^\`]*?\b(?&attrValue)\b[^\`]*+\`|
(?&attrValue)(?=[\s\>])
)
)
#В зависимости от того, какую из 2 функций выше мы хотим использовать для проверки атрибута
#Строгое сравнение значения
(?<tag>\<(?&tagName)\b\s*+(?&anyAttr)*?(?&attr)(?&anyAttr)*?\>) #Использовать так: (?&tag)
#Поиск значения как в классах
(?<tagClass>\<(?&tagName)\b\s*+(?&anyAttr)*?(?&attrClass)(?&anyAttr)*?\>) #Использовать так: (?&tagClass)
) #Этот огровный блок с функциями закончился
(?:[^\<]++(*SKIP)|\G|\C*?(?<parentTag>(?&tagClass)))[^\<]*+\K #После того, как нашли тег сбросили состояние нулевой группы
(?<openTag>\<li\b\s*+(?&anyAttr)*+\>) #У тега могут быть атрибуты
(?<innerHTML>\C*?) #Внутреннее содержимое тега
(?<closeTag>
\<\/li\b\s*+(?&anyAttr)*+>| #В HTML у закрывающих тегов нет атрибутов, но HTML от этого не ломается
(?=(?&openTag))| #Теги элементов списка необязательно закрывать согласно документации
(?=(?<closeParentTag>\<\/ul\b\s*+(?&anyAttr)*+\>)) #Закрытие списка закрывает последний элемент
)"#).unwrap();
let string = "<ul>
<li class=\"li anyClass\">aaa</li>
<li>bbb
<li>ccc
</ul>
<p>какой-то текст</p>
<ul data-class=\"ul anyClass\" class=\"ul anyClass\" data-id=`ul` id='ul' data-data=ul data-empty>
<li class=\"li anyClass\">aaa</li>
<li >aaa</li>
<li>bbb
<li>ccc
</ul>
<p>какой-то текст</p>
<ul>
<li class=\"li anyClass\">aaa</li>
<li>bbb
<li>ccc
</ul>
<p>какой-то текст</p>
<ul data-class=\"ul anyClass\" class=\"ul anyClass\" data-id=`ul` id='ul' data-data=ul data-empty>
<li class=\"li anyClass\">aaa</li>
<li>bbb
<li>ccc
</ul>
<p>какой-то текст</p>
<ul>
<li class=\"li anyClass\">aaa</li>
<li>bbb
<li>ccc
</ul>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}