$re = '/([^0-9]|^)3\.4\.5\.1([^.0-9]|$)/m';
$str = '3.4.5.1 3.4.5.1.3 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);