$re = '/(?!^)(?:\/[^\/]+)+\//';
$str = '/member-directory/john-doe/bp-memberships/?action=cancel&sub=12 ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);