import Foundation
let pattern = #"\b(\d{3})(\d{3})(\d{4})\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
reformat several 10-digit numeral strings to telephone number format
Hello. I'm looking for regex to use with LibreOffice Calc find-and-replace function to format 10-digit numbers into telephone number format. Example: reformat
4018286606 to be (401) 828-6606
I tried this:
FIND (\[0-9\]{10})
REPLACE WITH \^(\\(\[0-9\]{3}\\)\\s\[0-9\]{3}-\[0-9\]{4})
Not working.
Using LibreOffice [25.8.4.2](http://25.8.4.2)
Thank you.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"($1) $2-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)