package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:([-‐‑‒–—―−⁃﹘﹣-])|(?:&(?:(?:#x(2d|201[0-5]|2212|2043|fe58|fe63|ff0d))|(?:#(45|820[89]|821[0123]|8722|8259|65112|65123|65293))|(hyphen|[nm]?dash|hybull|horbar|minus));?))`)
var str = `This captures an entity even if it lacks the ';', which is commonly encountered in the wild.
kbdash - - - - -; -
dash ‐ ‐ ‐ ‐ ‐ ‐; ‐
hyphen ‑ ‐ ‑ ‑ ‑ ‑; ‑
figure ‒ ‒ ‒ ‒ ‒; ‒
em – – – – – –; –
en — — — — — —; —
horbar ― ― ― ― ― ―; ―
minus − − − − − −; −
hybull ⁃ ⁃ ⁃ ⁃ ⁃ ⁃; ⁃
fe58 ﹘ ﹘ ﹘ ﹘ ﹘; ﹘
fe63 ﹣ ﹣ ﹣ ﹣ ﹣; ﹣
ff0d - - - - -; -
(?:([-‐‑‒–—―−⁃﹘﹣-])|(?:&(?:(?:#x(2d|201[0-5]|2212|2043|fe58|fe63|ff0d))|(?:#(45|820[89]|821[0123]|8722|8259|65112|65123|65293))|(hyphen|[nm]?dash|hybull|horbar|minus));?))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}