$re = '/\w+(?:\s+\w+)*[.?!]\s*/m';
$str = 'More writing. More writing? More writing!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);