re = /(?<=\\t\(.*?\\fn).*(?=\)|\\)/m
str = '\\t(\\fnJester (BIG))
\\t(\\fnJester (BIG))\\i1
\\t(\\fnJester (BIG)
\\t(\\fnJester))))\\fnArial (BOLD)\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end