$re = '/[-+]?\d*\.?\d+/m';
$str = '
123
sfg44
sgf -123
1
+1
113
12324
-
+
sfgsfsg 113.13
.13 ssgfsf
-.23
-0.23
sfgsgf -134.14
+14.14
sfv
+sfv
-sfv
-3.1
.
100%
hsl(171, 100%, 92%)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);