package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<\/[a-z]+\s*\r?\n+^[a-z]+>)`)
var str = ` <gcusf><gcusfname>SEND-SU-01</gcusfname>
<gcusfvalue>'||"TO CHECK AUTOMATIC DISCART FOR USER"'</gc
usfvalue>
</gcusf>
<gcrvalf>YYMMDD</gcrvalf><gcrvalt>YYMMDD</gcrvalt>
<gcrundesc>'MY DESC YYMMDD -L2,-L4,-L5 OF WEEK'</gcrunde
sc><gcrunrule>E</gcrunrule><gcrtype>N</gcrtype><gcriat>2300</gcriat>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}