# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"[a-zA-Z0-9 -\/\[\]_:.\(\)@\"\-,]*\",|[\"[a-zA-Z0-9 -\/\[\]_:.\(\)@\"\-,]*\"],|},"
test_str = ("{\n"
"\"slug\": \"submit/82276720931155/\",\n"
"\"file_server\": \"go-sub3\",\n"
"\"temp_upload\": {\n"
"\"q95_input95\": [\"iShares-Fund-Changes-June-2018-vF.PDF\"]\n"
"},\n"
"\"q44_gi_LegalEntityName\": \"Test 96\",\n"
"\"q43_gi_Address\": {\n"
"\"addr_line1\": \"96\",\n"
"\"addr_line2\": \"\",\n"
"\"city\": \"New York\",\n"
"\"state\": \"NY\",\n"
"\"postal\": \"10096\",\n"
"\"country\": \"United States\"\n"
"},\n"
"\"q45_gi_PhoneNumber\": {\n"
"\"full\": \"(969) 696-9696\"\n"
"},\n"
"\"q47_gi_FaxNumber\": {\n"
"\"full\": \"\"\n"
"},\n"
"\"q48_gi_CompanyWebsite\": \"\",\n"
"\"q49_gi_DateOfIncorporation\": {\n"
"\"year\": \"\",\n"
"\"month\": \"\",\n"
"\"day\": \"\"\n"
"},\n"
"\"q50_gi_StateOfIncorporation\": {\n"
"\"addr_line1\": \"\",\n"
"\"addr_line2\": \"\",\n"
"\"city\": \"\",\n"
"\"state\": \"\",\n"
"\"postal\": \"\",\n"
"\"country\": \"\"\n"
"},\n"
"\"q51_gi_TaxID\": \"96\",\n"
"\"q58_gi_RegulatoryAuth\": \"\",\n"
"\"q59_gi_LeiNumber\": \"\",\n"
"\"q60_gi_LargeTraderID\": \"\",\n"
"\"q62_gi_ComplianceContact\": {\n"
"\"first\": \"\",\n"
"\"last\": \"\"\n"
"},\n"
"\"q64_gi_ComplianceEmail\": \"\",\n"
"\"q63_gi_CompliancePhoneNumber\": {\n"
"\"full\": \"\"\n"
"},\n"
"\"q67_gi_IsSubsidiaryName\": \"\",\n"
"\"q68_gi_IsSubsidiaryAddress\": \"\",\n"
"\"q69_gi_IsSubsidiaryJurisdiction\": \"\",\n"
"\"q70_gi_IsSubsidiaryRegulator\": \"\",\n"
"\"q75_sc_OpsContact\": {\n"
"\"first\": \"\",\n"
"\"last\": \"\"\n"
"},\n"
"\"q77_sc_OpsEmail\": \"\",\n"
"\"q76_sc_OpsPhone\": {\n"
"\"full\": \"\"\n"
"},\n"
"\"q80_sc_OmgeoAcronym\": \"\",\n"
"\"q81_sc_OmgeoAccessCode\": \"\",\n"
"\"q82_sc_DTCNumber\": \"\",\n"
"\"q83_sc_MPID\": \"\",\n"
"\"q84_sc_AgentBankNumber\": \"\",\n"
"\"q85_sc_InternalAccountNumber\": \"\",\n"
"\"q86_sc_InstDelivery\": \"\",\n"
"\"q87_sc_InterestedPartyID\": \"\",\n"
"\"q88_sc_Custodian\": \"\",\n"
"\"q89_sc_Euroclear\": \"\",\n"
"\"q90_sc_Cedel\": \"\",\n"
"\"q92_sc_ConfirmsEmail\": \"\",\n"
"\"q101_ct_InstitutionalDVP\": {\n"
"\"other\": \"\"\n"
"},\n"
"\"q102_ct_InstitutionalDVPTypePublicDescription\": \"\",\n"
"\"q108_ct_SectionA\": [\"Trust Co.\"],\n"
"\"q114_ct_SectionC\": {\n"
"\"other\": \"\"\n"
"},\n"
"\"q116_id_SectionA\": {\n"
"\"0\": \"For a corporation, a Corporate Resolution and, if available, incorporation documents such as Articles of Incorporation and By-Laws\",\n"
"\"other\": \"\"\n"
"},\n"
"\"q121_ac_ControllingCustomerRelationship\": \"\",\n"
"\"q123_ac_RegulatorBeneficialOwner\": \"No\",\n"
"\"q125_ac_AccountBase\": \"\",\n"
"\"q130_ac_CommercialEntity\": \"\",\n"
"\"q132_ac_CommercialEntityOutsideUSFundsCountry\": {\n"
"\"addr_line1\": \"\",\n"
"\"addr_line2\": \"\",\n"
"\"city\": \"\",\n"
"\"state\": \"\",\n"
"\"postal\": \"\",\n"
"\"country\": \"\"\n"
"},\n"
"\"q152_ac_ConfirmNeitherPrivBank\": {\n"
"\"other\": \"\"\n"
"},\n"
"\"q138_ac_CustomerRelationship\": \"Hi\",\n"
"\"q161_signature\": \"Signed by David Test (dd@brownstone.com)\",\n"
"\"q56_approvalStatus\": \"\",\n"
"\"q159_ip\": \"\",\n"
"\"q57_typeA\": \"https://form.jotform.com/82276720931155\",\n"
"\"event_id\": \"1537887682362_82276720931155_ZPG71XZ\",\n"
"\"q66_gi_IsSubsidiary\": \"\",\n"
"\"q78_sc_Omgeo\": \"\",\n"
"\"q91_sc_Confirms\": \"\",\n"
"\"q97_sc_StructuredSecurities\": \"\",\n"
"\"q98_sc_StructuredSecuritiesUnderstand\": \"\",\n"
"\"q105_ct_MunicipalEntity\": \"\",\n"
"\"q109_ct_SectionA2\": \"\",\n"
"\"q111_ct_SectionB\": \"\",\n"
"\"q112_ct_SectionBRelyingAdviser\": \"\",\n"
"\"q120_ac_ControllingCustomer\": \"\",\n"
"\"q126_ac_AMLProgram\": \"\",\n"
"\"q128_ac_AMLRepresentationType\": \"\",\n"
"\"q131_ac_CommercialEntityOutsideUSFunds\": \"\",\n"
"\"q133_ac_CommercialEntityOutsideUSPresence\": \"\",\n"
"\"q134_ac_CommercialEntityOutsideUSServiceShellBanks\": \"\",\n"
"\"q157_id_SectionANA\": \"\",\n"
"\"input95\": [\"https://www.jotform.com/uploads/ddinner/82276720931155/4136970043522095790/iShares-Fund-Changes-June-2018-vF.PDF\"]\n"
"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.