$re = '/(?:(\w+):)?(?:(\w+)=([^;]+);?)/';
$str = 'pgsql:host=ltt-clickhouse;port=8123;database=default;connect_timeout_with_failover_ms=10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);