import re
regex = re.compile(r"(^.*)(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%n@%m%)(?:{\$\w*%})\s(?:%{\$\w*\[\w*\]\$\w*\[\w*\]%})(%~)(?:%{\$\w*%})(\s*\$\(\w*\))")
test_str = ("╭─%{$terminfo[bold]$fg[green]%}%n@%m%{$reset_color%} %{$terminfo[bold]$fg[blue]%}%~%{$reset_color%} $(git_prompt_info)%{$reset_color%}\n"
"╰─%B╼%b\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")