$re = '/\b1Z[A-Z0-9]{16}\b/m';
$str = '1ZW6897X0327621544';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);