$re = '%<link\s+(?:[^>]*?\s+)?href=(["\']).*?(fonts\.googleapis\.com).*?\1*>%';
$str = '<!-- joomla head -->
<link href="https://musterdomain.at/images/icon.png" rel="shortcut icon" type="image/png" sizes="any" /><link href="https://fonts.googleapis.com/css2?family=Open+Sans:ital,wght@0,300;0,400;0,600;0,700;0,800;1,300;1,400;1,600;1,700;1,800&display=swap" rel="stylesheet" type="text/css" />
<link href="https://fonts.googleapis.com/css2?family=Ubuntu:ital,wght@0,300;0,400;0,500;0,700;1,300;1,400;1,500;1,700&display=swap" rel="stylesheet" type="text/css" />
<link href="https://fonts.googleapis.com/css2?family=Ropa+Sans:ital,wght@0,400;1,400&display=swap" rel="stylesheet" type="text/css">
<link href="https://musterdomain.at/media/system/css/joomla-fontawesome.css?e9f3c2476322ea574b407689a02666d5" rel="stylesheet" type="text/css" />
<link href="https://use.fontawesome.com/releases/v6.2.0/css/all.css" data-version="6.2.0" rel="stylesheet" type="text/css" />
<link href="https://musterdomain.at/media/templates/site/tp_easy/css/compiled-901cb97c530df6ff377f9a49a4c09cd4.css?e9f3c2476322ea574b407689a02666d5" rel="stylesheet" type="text/css" />
<link href="https://musterdomain.at/media/astroid/assets/vendor/astroid/css/debug.css?e9f3c2476322ea574b407689a02666d5" rel="stylesheet" type="text/css" />
<link href="https://musterdomain.at/media/templates/site/tp_easy/css/compiled-dbb71e3836394a80bbece49d2d30c5be.css?e9f3c2476322ea574b407689a02666d5" rel="stylesheet" type="text/css" />
<!-- head styles -->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);