const regex = /^(?!enum).*class\b\s\b[A-Za-z_][A-Za-z_0-9]*\b\s*($)?(|:\s*($)?(public|private|protected))\s*(.*?)\s*(({$)|(}$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!enum).*class\\b\\s\\b[A-Za-z_][A-Za-z_0-9]*\\b\\s*($)?(|:\\s*($)?(public|private|protected))\\s*(.*?)\\s*(({$)|(}$))', 'gm')
const str = `using UnityEngine;
namespace test{
public class PlayerController : MonoBehaviour { }
public class DoorControl : MonoBehaviour
{
private class DoorControl : MonoBehaviour
{
public class DoorControl
{
public static class DoorControl
{
public class DoorControl {
public class DoorControl : MonoBehaviour, test
{
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}