#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?:\/(?:[0-9]|[12][0-9]|3[0-2]))?|(?:[0-9a-fA-F]{1,4}:){7}[0-9a-fA-F]{1,4}|(?:[0-9a-fA-F]{1,4}:){1,7}:|(?:[0-9a-fA-F]{1,4}:){1,6}:[0-9a-fA-F]{1,4}|(?:[0-9a-fA-F]{1,4}:){1,5}(?::[0-9a-fA-F]{1,4}){1,2}|(?:[0-9a-fA-F]{1,4}:){1,4}(?::[0-9a-fA-F]{1,4}){1,3}|(?:[0-9a-fA-F]{1,4}:){1,3}(?::[0-9a-fA-F]{1,4}){1,4}|(?:[0-9a-fA-F]{1,4}:){1,2}(?::[0-9a-fA-F]{1,4}){1,5}|[0-9a-fA-F]{1,4}:(?::[0-9a-fA-F]{1,4}){1,6}|:(?::[0-9a-fA-F]{1,4}){1,7}|::)(?:\/(?:[0-9]|[1-9][0-9]|1[0-1][0-9]|12[0-8]))?$"
Local $sString = "127.1.1.123" & @CRLF & _
"" & @CRLF & _
"0000:0000:0000:0000:0000:0000:0000:0000" & @CRLF & _
"" & @CRLF & _
"ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff" & @CRLF & _
"" & @CRLF & _
"127.0.0.112" & @CRLF & _
"" & @CRLF & _
"127.1.1.1/24" & @CRLF & _
"" & @CRLF & _
"123.0.0.1/33" & @CRLF & _
"" & @CRLF & _
"2001:db8::123/23" & @CRLF & _
"" & @CRLF & _
"2001:db8:1234:1a00::/64" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"127.0.0.1/92"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")