# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([-.a-z0-9]+:\/{1,3})([^-/\.[\](|)\s?][^`\/\s\]?]+)([-_a-z0-9!@$%^&*()=+;/~\.]*)[?]?([^#\s`?]*)[#]?([^#\s'\"`\.]*)"
test_str = ("DB_URL=postgresql://postgres:postgres@localhost/postgres?timeout=0\n"
"# Damn, Daniel!\n\n"
"Bob: have you checked https://www.facebook.com?\n"
"lorem https://github.com/justsml?tab=activity#top ipsum\n"
"smb:///winbox/dfs/ - ipp://printer\n"
"leading text chrome-extension://flags??#\n"
"s3://buckets/for/all?true=true\n"
"s3:///////buckets-o-fun\n"
"pkcs11://because-pkcs7-is-weak#only=hash\n"
"\\||@@https://www.google.com <- should match when extracting\n"
"https://we - this is valid\n"
"s3://buckets-o-fun/!hi/raw=val&#keep=hashin'?\n"
"hi. pkcs11://because-pkcs7-is-weak\n"
"hi. a://b/c?d=e#f=g && a://b/c?d]\n"
"hi. chrome-extension://flags hi. \n"
"hi. ms-help://good-luck/index.html hi. \n"
"hi. .iris.beep://really/dots. hi. \n"
"hi. iris.beep://really/dots?test=qs hi. \n"
"---\n"
"a://b]/c - Should match `a://b` - it's smallest match.\n"
"http://www.c:ool.com.au - this one's tricky, should match auth URIs: proto://user:pass@host. Including cases where the password could be omitted (`proto://user@host`.)\n\n"
"Invalid Examples:\n"
"https://www...google...com\n"
"https://we@.com\n"
"https://asdas-.com\n"
"http://-apple-.com\n"
"https://...honda.com\n"
"http://aaa.com.co.com:8080/test?dan=dev#den\n\n"
"a://(b/c\n"
"chrome-extension)://flags\n"
"ms-help://|good-luck.html\n"
"boop://really-/ -- technically domains shouldn't end in dashes or other 'special' chars, but this is technically a valid URI.\n"
". , ; : ) ] } \n"
"a://b./c?d. -- bad dns, trailing dot: tricky w/o look-arounds. (Adding an OR pattern would muddle the returned data indexes.)\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.