re = /\|\|[0-9]+\s*[0-9]+\s*\|\|([0-9]{6}-[0-9]{4}-[0-9]{3}\S*)\|\|.*?Bestellnr\.K\/Pos\s*?([0-9]+)\s*?([0-9]+)\|\|.*?Charge:\s*?(\S+)\s*?Gesamtmenge:\s*?([0-9\.]+)\s*?ST/m
str = '||10 980008530||000000-2209-165-EXE||Unverl. Kombischr._M5x25_UE_Nitronic_ISR||Nitronic60||3fach verpackt||10er Setverpackung||Reinigung und Verpackung nach VACOM Purity Class 4 / ZEISS 1000711||Bestellnr.K/Pos 1926779 1||Ihre Materialnr.: 000000000002209165-EXE||Charge: 0009114369 Gesamtmenge: 999 ST||Handling Unit: 10030337466 999 ST||20 980008530||000000-1234-999-EXE||Unverl. Kombischr._M5x25_UE_Nitronic_ISR||Nitronic60||3fach verpackt||10er Setverpackung||Reinigung und Verpackung nach VACOM Purity Class 4 / ZEISS 1000711||Bestellnr.K/Pos 1926779 1||Ihre Materialnr.: 000000000002209165-EXE||Charge: 0009114369 Gesamtmenge: 123456 ST||Handling Unit: 10030337466 999 ST||30 980008530||000000-8888-165-EXE||Unverl. Kombischr._M5x25_UE_Nitronic_ISR||Nitronic60||3fach verpackt||10er Setverpackung||Reinigung und Verpackung nach VACOM Purity Class 4 / ZEISS 1000711||Bestellnr.K/Pos 1926779 1||Ihre Materialnr.: 000000000002209165-EXE||Charge: 0009114369 Gesamtmenge: 999 ST||Charge: 000777777 Gesamtmenge: 22222 ST||Handling Unit: 10030337466 999 ST'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end