$re = '/^[0-9]+$|^[A-Z]{3}[0-9]{3}$/m';
$str = 'ABC123
12345
HHHH888
yyyy
KKKKK
K81818';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);