#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<nr_classe>(\d{4,}))([\x20\t\-]{1,}|[a-zA-Z]|$)"
Local $sString = "250156304 - 6 ANO A INTEGRAL ANUA" & @CRLF & _
"250156445 - 7 ANO A INTEGRAL ANUA" & @CRLF & _
"250794211 - 2ª SERIE A INTEGRAL ANUA" & @CRLF & _
"250794484 - 2ª SERIE B INTEGRAL ANUA" & @CRLF & _
"250795069 - 3ª SERIE A INTEGRAL ANUA" & @CRLF & _
"250795291 - 3ª SERIE B INTEGRAL ANUA" & @CRLF & _
"250797255 - 6 ANO A INTEGRAL ANUA" & @CRLF & _
"250797644 - 7 ANO A INTEGRAL ANUA" & @CRLF & _
"250797800 - 7 ANO B INTEGRAL ANUA" & @CRLF & _
"250798147 - 8 ANO A INTEGRAL ANUA" & @CRLF & _
"250798493 - 9 ANO A INTEGRAL ANUA" & @CRLF & _
"250798725 - 9 ANO B INTEGRAL ANUA" & @CRLF & _
"251327540 - 8 ANO A TARDE ANUA" & @CRLF & _
"251327755 - 8 ANO B TARDE ANUA" & @CRLF & _
"251328951 - 7 ANO A TARDE ANUA" & @CRLF & _
"251329173 - 7 ANO B TARDE ANUA" & @CRLF & _
"251329173 -7 ANO B TARDE ANUA" & @CRLF & _
"251331013 - 6 ANO A TARDE ANUA" & @CRLF & _
"252381546 - 6074 - INFORMATICA PARA INTERNET - 1ª SERIE NT MANHA ANUA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")