const regex = /_a?b?c?_(?<!__)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_a?b?c?_(?<!__)', 'gm')
const str = `_a_
_b_
_ac_
_abc_
_ba_
_ca_
__`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}