#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=\w*\s\w*\sNIF\/CIF)(?<cRegexGroupsName>.*?)\s(?=\w*\sNIF\/CIF)"
Local $sString = "Dirección Provincial de: BIZKAIAUnidad de Recaudación Ejecutiva nº: 48/08Apellidos y nombre/R.Social: INFRAESTRUCTURAS VAL DIN 2001 S.A.0A95123568 812000059562248 NIF/CIF: Nº de referencia: Domicilio: CL BERTENDONA 4 3 DP3 Tipo/Identificador: 10 48105556974 Régimen: 0111 Localidad: 48008 BILBAO Expediente: 48 08 20 00069160 Importe deuda pendiente: 122.779,79 Nº Documento: 48 08 312 20 025162050 DILIGENCIA DE EMBARGO DE CUENTAS CORRIENTES Y DE AHORRO (TVA-312) DESTINATARIO:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")